Информатика, вопрос задал quendelin , 9 лет назад

Добрый вечер!
Помогите, пожалуйста, написать программу.
В двухмерном массиве элементы главной диагонали заменить числом k

Ответы на вопрос

Ответил sergiyremez
0
Если массив квадратный то можно
Ответил sergiyremez
0
Решение давать?
Ответил sergiyremez
0
uses crt;
const n=3;
var a:array[1..n,1..n]of integer; i,j,k:integer;
begin
clrscr; randomize; k:=random(10)+1;
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:=random(10)+1;
write(a[i,j]:4);
end;
writeln;
end;
for i:=1 to n do
begin
for j:=1 to n do
begin
if i=j then begin a[i,j]:=k; end;
end;
end;
for i:=1 to n do
begin
for j:=n downto 1 do
begin
if (i+j=4) then begin a[i,j]:=k; end;
end;
end;
writeln;
for i:=1 to n do
begin
for j:=1 to n do
begin
write(a[i,j]:4);
end;
writeln;
end;
Ответил sergiyremez
0
readkey;
Ответил sergiyremez
0
end.
Новые вопросы