Информатика, вопрос задал Lola19950106 , 9 лет назад

Добрый день. Нужна помощь в паскале.
Необходимо составить программу подсчёта количества нулевых элементов в массиве А(100).
Буду премного благодарен. Спасибо.

Ответы на вопрос

Ответил Аноним
0
const
  n=100; { размер массива }
var
  a:array[1..n] of integer;
  i,k:integer;
begin
  { заполняем массив случайными значениями }
  Randomize;
  k:=0;
  Writeln('Элементы массива');
  for i:=1 to n do
    begin
    a[i]:=Random(41)-20;
    Write(a[i],' ');
    if a[i]=0 then Inc(k)
    end;
  Writeln;  
  Writeln('Нулевых элементов: ',k)
end.

Новые вопросы