Доброго времени суток! Пожалуйста, помогите написать программу на С++ для решения задачи.
Дано целое число n. Выведите следующее за ним четное число. При решении этой задачи нельзя использовать условную инструкцию if и циклы.
Входные данные
Вводится целое число.
Выходные данные
Выведите ответ на задачу.
Ответы на вопрос
Ответил petyaGavrikov
0
#include <iostream>
using namespace std;
int main()
{
int n, m;
cout << "n = ", cin >> n, cout << "n";
m = n + 1 + (n+1)%2;
cout << "m = " << m;
return 0;
}
Пример:
n = 17
m = 18
using namespace std;
int main()
{
int n, m;
cout << "n = ", cin >> n, cout << "n";
m = n + 1 + (n+1)%2;
cout << "m = " << m;
return 0;
}
Пример:
n = 17
m = 18
Новые вопросы
История,
2 года назад
История,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Литература,
9 лет назад