Для решения задачи необходимо составить программу на языке программирования и сохранить ее под именем для проверки отправить учителю.
Задача 2. Разность времен (100 баллов)
Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из моментов времени. Известно, что второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени.
Входные данные
Программа на вход получает три целых числа — часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени.
Выходные данные
Выведите число секунд между этими моментами времени.
Примеры
Ввод Вывод
1
1
1
2
2
2 3661
1
2
30
1
3
20 50
Ответы на вопрос
Ответил petyaGavrikov
0
// PascalABC.NET 3.3
begin
var (h1,m1,s1):=ReadInteger3;
var (h2,m2,s2):=ReadInteger3;
writeln((h2*60*60+m2*60+s2)-(h1*60*60+m1*60+s1));
end.
Пример:
1 1 1
2 2 2
3661
begin
var (h1,m1,s1):=ReadInteger3;
var (h2,m2,s2):=ReadInteger3;
writeln((h2*60*60+m2*60+s2)-(h1*60*60+m1*60+s1));
end.
Пример:
1 1 1
2 2 2
3661
Новые вопросы