Информатика, вопрос задал Gorchakoffart , 8 лет назад

ДЛЯ ПИТОНА

Выведите значение наименьшего нечетного элемента списка, а если в списке нет нечетных элементов - выведите число 0.

Входные данные
Вводится список чисел. Все числа списка находятся на одной строке.

Выходные данные
Выведите ответ на задачу.

Примеры
входные данные
0 1 2 3 4
выходные данные
1
входные данные
2 4 6 8 10
выходные данные
0

Ответы на вопрос

Ответил krenovut
0
Наверно сортировкой пользоваться нельзя, да?

num = list(map(int, input().split()))
min= 0
for i in range(len(num)):
    if num[i] % 2 == 1:
        min= num[i]
        break
for i in range(len(num)):
    if num[i] % 2 == 1:
        if num[i] < min:
            min = num[i]
if min != 0:
    print(min)
else:
    print(0)
Давно не прогал на питоне, поэтому забыл уже разные интересные плюшки. Так что решил, так сказать, в лоб. 1 циклом находишь 1 нечетное, 2 циклом сравниваешь весь массив с этим числом. если ни там ни там ничего не было, то 0.  Должно работать 
Ответил Gorchakoffart
0
Syntax Error: invalid syntax: <string>, line 1, pos 3
Ответил Gorchakoffart
0
Простите, это я ошибся, все правильно
Ответил Gorchakoffart
0
Спасибо!
Новые вопросы