Информатика, вопрос задал Gorchakoffart , 8 лет назад

ДЛЯ ПИТОНА


Дана последовательность чисел, завершающаяся числом 0. Найдите сумму всех этих чисел, не используя цикл.

Входные данные
Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит, а служит как признак ее окончания).

Выходные данные
Выведите ответ на задачу.

Примеры
входные данные
1
7
9
0
выходные данные
17

Ответы на вопрос

Ответил hermanyanush2owupbd
0
Ну никто же не запрещал использовать мощные функции для работы со строками и ввод делать из файла))

file_text=open('my_input_file','r').read()
print(sum(map(int,file_text.split('n0')[0].split('n'))))

Хотя рекурсивный метод оказался ещё проще:

def sum_seq(sum):
    new_number=int(input())
    if (new_number != 0): return sum_seq(sum+new_number)
    return sum

sum_seq(0)








Новые вопросы