Для данных областей составить программу, которая печатает true, если точка с координатами (х, у) принадлежит закрашенной области, и false — в противном случае
Приложения:

Ответы на вопрос
Ответил Аноним
0
Уравнение окружности радиуса R, центр которой совпадает с началом системы координат в декартовой системе координат имеет вид
x²+y²=R²
Для данного случая можно записать x²+y²=6² или x²+y²=36.
Заштрихованная область находится внутри окружности и при этом x>2, т.е. является сегментом круга, поэтому условие принадлежности некоторой точки M(x,y) сегменту запишется в виде (x²+y²<36) ∩ x>2.
Если границы сегмента также принадлежат заштрихованной области, неравенства меняются на нестрогие: (x²+y²≤36) ∩ x≥2.
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!
begin
Write('Введите координаты x,y точки: ');
var (x,y):=ReadReal2;
Writeln((x*x+y*y<=36) and (x>=2))
end.
Пример
Введите координаты x,y точки: 3.5 4.8
True
x²+y²=R²
Для данного случая можно записать x²+y²=6² или x²+y²=36.
Заштрихованная область находится внутри окружности и при этом x>2, т.е. является сегментом круга, поэтому условие принадлежности некоторой точки M(x,y) сегменту запишется в виде (x²+y²<36) ∩ x>2.
Если границы сегмента также принадлежат заштрихованной области, неравенства меняются на нестрогие: (x²+y²≤36) ∩ x≥2.
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!
begin
Write('Введите координаты x,y точки: ');
var (x,y):=ReadReal2;
Writeln((x*x+y*y<=36) and (x>=2))
end.
Пример
Введите координаты x,y точки: 3.5 4.8
True
Новые вопросы
Українська мова,
2 года назад
Русский язык,
2 года назад
Математика,
8 лет назад
Алгебра,
9 лет назад