Информатика, вопрос задал mmxx531 , 2 года назад

Даю целых 30 баллов!
Напишите программу вычисления выражения на C++:
99 – 98 + 97 – 96 + 95 – 94 + ... + 5 – 4 + 3 – 2 + 1

Ответы на вопрос

Ответил restIess
1

#include <iostream>

using namespace std;

signed main() {

int s = 0;

for (int i = 99; i >= 1; i--) {

 if ((i & 1) == 0)

  s -= i;

 else

  s += i;

}

cout << s;

return 0;

}

Новые вопросы