ДАЮ 95 БАЛЛОВ. Заранее спасибо.
Написать программу для решения задач на Pascal ABC:
Даны три различных целых числа. Найти среднее из них. (Средним называется число, которое больше наименьшего и меньше наибольшего из данных чисел)
Найти наибольшее из трех заданных чисел.
Ответы на вопрос
Ответ:
Первый вариант:
program N60286025;
var a,b,c,m:integer;
begin
write('Введите 1-е число: ');
readln(a);
write('Введите 2-е число: ');
readln(b);
write('Введите 3-е число: ');
readln(c);
if (a <= b) and (b <= c) or (a >= b) and (b >= c) then m := b;
if (b <= a) and (a <= c) or (b >= a) and (a >= c) then m := a;
if (c <= b) and (a <= c) or (c >= b) and (a >= c) then m := c;
writeln('Среднее число ',m);
readln
end.
Второй вариант:
program N60286025;
var a,b,c,m:integer;
begin
write('Введите 1-е число: ');
readln(a);
write('Введите 2-е число: ');
readln(b);
write('Введите 3-е число: ');
readln(c);
if a <= b then
if a <= c then
if b <= c then
m := b
else
m := c
else
m := a
else
if a <= c then
m := a
else
if b <= c then
m := c
else m := b;
writeln('Среднее число ',m);
readln
end.