Информатика, вопрос задал alisa150204 , 7 лет назад

Даю 95 баллов!!!
Помогите пожалуйста написать программу для программирования:
Дана длина отрезка в см. Перевести см в метры, а метры в миллиметры.

Приложения:

Ответы на вопрос

Ответил petyaGavrikov
0

Программа на паскале:

var d: integer;

begin

write('Длина в см = ');

readln(d);

writeln(d, ' см = ', d/100:5:2,' м = ',d*10,' мм');

end.

Пример:

Длина в см = 15

15 см =  0.15 м = 150 мм

Ответил mydric
0

В питоне:

|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||

def start():

  print("Выберите")

  print("0 - См в М")

  print("1 - М в Мм")

  read = input()

  if (read == "0"):

     ooo()

  elif (read == "1"):

     aaa()

  else:

    print("Нет такого выбора")

    inf()

def ooo():

  print("Введите значение")

  cm = input()

  math = 100

  result = float(cm) / math

  print(result)

  start()

def aaa():

  print("Введите значение")

  m = input()

  math = 1000

  result = float(m) * math

  print(result)

  start()

def inf():

  read = input()

  if (read == "0"):

     ooo()

  elif (read == "1"):

     aaa()

  else:

    print("0 - См в М")

    print("1 - М в Мм")

    print("Нет такого выбора")

    inf()

start()

|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||

Новые вопросы