Информатика, вопрос задал kolyasick1 , 8 лет назад

Даю 75 баллов! Напишите программу, которая в списке из десяти случайных целочисленных элементов из диапазона от 0 до 100 находит максимальный чётный и минимальный нечётный элементы.

Ответы на вопрос

Ответил Giammy
0
PascalABC.NET
Версия 3.3. сборка 1583 (25.11.2017)

var a:array[1..10] of integer;
begin
 var max:=2;
 var min:=101;
 for var i:=1 to 10 do
 begin
  a[i]:=random(0,100);
  write(a[i],' ');
  if (a[i] mod 2=0) and (a[i]>max)
    then max:=a[i];
   if (a[i] mod 2=1) and (a[i]<min)
    then min:=a[i];
 end;
  writeln;
  writeln('Минимальный нечетный елемент - ',min);
  writeln('Максимальный четный елемент - ',max);
readln;
end.
Новые вопросы