Даю 60 баллов! Помогите!
1.
Даны x, y, z. Напишите программу для вычисления значения арифметических выражений.
a= (x + y - z) / (x² + 2)
2.
Составте программу для решения задачи.
На кондитерской фабрике конфеты из бункера, вмещающего S кг конфет, упаковывают в коробки по N г. Сколько коробок будет заполнено? Сколько г конфет будет в незаполненной коробке?
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!
№1
begin
var (x,y,z):=ReadReal3('Введите x,y,z');
var a:=(x+y-z)/(x*x+2);
Writeln(a)
end.
№2
begin
var (s,n):=ReadInteger2('Введите S,N:');
s*=1000; // перевод в граммы
Writeln('Будет заполнено коробок: ',s div n);
Writeln('В незаполненной коробке останется вес, г: ', s mod n)
end.
// Внимание! Если программа не работает, обновите версию!
№1
begin
var (x,y,z):=ReadReal3('Введите x,y,z');
var a:=(x+y-z)/(x*x+2);
Writeln(a)
end.
№2
begin
var (s,n):=ReadInteger2('Введите S,N:');
s*=1000; // перевод в граммы
Writeln('Будет заполнено коробок: ',s div n);
Writeln('В незаполненной коробке останется вес, г: ', s mod n)
end.
Новые вопросы
Химия,
2 года назад
История,
2 года назад
Музыка,
8 лет назад
Геометрия,
8 лет назад
Математика,
9 лет назад