Информатика, вопрос задал evanesterova2007 , 1 год назад

ДАЮ 60 баллов
15.2 Напишите программу для решения следующей задачи. Девятиклассники участвовали в викторине по математике.
Необходимо было ответить на 20 вопросов. Победителем викторины считается участник, правильно ответивший на наибольшее
количество вопросов. На сколько вопросов победитель ответил правильно? Если есть участники викторины, которые не смогли
дать правильный ответ ни на один из вопросов, выведите YES, иначе выведите NO. Гарантируется, что есть участники,
правильно ответившие хотя бы на один из вопросов. Программа получает на вход число участников викторины N (1 5 N 5 50),
затем для каждого участника вводится количество вопросов, на которые получен правильный ответ.
Пример работы программы:
Входные данные Выходные данные
4
17
15
12
0
17
ЧЕРЕЗ МАССИВ НА ПИТОНЕ

Ответы на вопрос

Ответил Makar07
0

maxi = 0

num = 0

n = int(input())

for i in range(n):

   a = int(input())

   if a > maxi: maxi = a

   if a == 0: num = 1

print(maxi)

if num > 0:

   print('YES')

else:

   print('NO')

Новые вопросы