Информатика, вопрос задал esstry , 1 год назад

Даю 50 баллов.
Помогите написать программу на С++

Приложения:

leonidkorolev2007: Это с использованием enum? Есть образец?
esstry: Да. Я уже не могу фото прикрепить. Enum constant_set { csconstant1 = 0. И тд} c_set; Дальше там будут switch, case...

Ответы на вопрос

Ответил leonidkorolev2007
1

Ответ:

#include <iostream>

using namespace std;

enum myenum { const1 = 5, const2 = 4, const3 = 3, const4 = 2, const5 = 1, const6 = 0 };

int main() {

 int a;

 cin >> a;

 switch (a)

 {

 case const1:case const2:case const3:

  cout << "first part";

  break;

 case const4:case const5:case const6:

  cout << "secont part";

  break;

 default:

  cout << "Error!";

  break;

 }

}

Объяснение:

Новые вопросы