Информатика, вопрос задал llax3127p6pjrf , 7 лет назад

Даю 50 баллов!!

Написать программу на языке python

F(n)=1 при n=1

F(n)=n+F(n-1), если n чётно,

F(n)=2*F(n-2), если n>1 и нечётно

Вывести F(25)

Ответы на вопрос

Ответил bilanovfatim
1

Ответ:

def F(n):

 if n == 1:

   return 1

 elif n % 2 == 0:

   return n + F(n-1)

 elif n % 2 != 0:

   return 2*F(n-2)

 

print(F(25))

Новые вопросы