Информатика, вопрос задал Ufa102rusq , 2 года назад

Даю 50 баллов информатика! Написать программу на Python.

Приложения:

Ответы на вопрос

Ответил merkkaa
0

num = []

count = 0

while 1:

   a = int(input())

   if a == 0: break

   elif count == 100: break

   elif a > 300:

       continue

   num.append(a)

   count += 1

num = list(filter(lambda x: (x % 8 == 0), num))

print(round(sum(num)/len(num), 1)) if len(num) != 0 else print("NO")

Новые вопросы