Информатика, вопрос задал Dimasicos88 , 6 лет назад

Даю 50 баллов 8класс

Написать программу, которая запрашивает сколько случайных чисел вывести на экран. Затем запрашивает интервал для случ.чисел. Выводит эти случайные числа и находит их сумму.

Пример:

Ввод:

Сколько случ. чисел нужно сгенерировать = 5

Интервал мин= -10

Интервал макс= 10

Вывод:

-3 6 3 0 -2

Сумма=4

Ответы на вопрос

Ответил alexshor
1

Ответ:

Результат в приложении

Объяснение:

#!/usr/bin/env python3

import random

n = int(input('Сколько случ. чисел нужно сгенерировать = '))

nmin = int(input('Интервал мин = '))

nmax = int(input('Интервал макс = '))

numbers = []

sum = 0

for i in range(0, n+1):

   num = random.randint(nmin, nmax)

   numbers.append(num)

   sum += num

print(numbers)

print('Сумма =', sum)

Приложения:
Новые вопросы