Информатика, вопрос задал krolik12351 , 7 лет назад

Даю 35 баллов !!!!
Написать программу на языке программирования в паскале:
Найти все целые числа из промежутка от 100 до 300, у которых сумма делителей равна K?(K вводится с клавиатуры)​

Ответы на вопрос

Ответил bena1976
0

var i,k,j,s:integer;

begin

  readln(k);

  FOR I:=100 TO 300 DO

  begin

     s:=0;

     for j:=1 to i do

     if i mod j=0 then s:=s+j;

     if s=k then writeln(i);

 end;

end.

Новые вопросы