Информатика, вопрос задал maksosokin01 , 7 лет назад

ДАЮ 34 БАЛЛА !!! ИНФОРМАТИКА ПОМОГИТЕ ) pascal
Исследователи решили проанализировать участки ДНК двух образцов. Каждый участок ДНК имеет некоторый состав нуклеотидов. Нуклеотиды ДНК образованы одним из следующих азотистых оснований: аденин, гуанин, тимин, цитозин, которые кодируются в цепочках ДНК при помощи заглавных букв по первой букве основания А, Г, Т, Ц, соответственно. Помогите учёным определить долю расхождений в цепочках ДНК, если под расхождением понимается неравенство соответствующих нуклеотидов в цепочках, находящихся на одной позиции, считая от левого края. Формат входных данных На вход программе подаётся целое число N (1≤N≤107). Затем две строки в каждой из которых записана цепочка длиной N из латинских букв A, G, T, C, соответствующих азотистым основаниям. Формат выходных данных Единственное число — ответ на задачу с точностью не ниже 10−7. Система оценки Баллы за задачу будут начисляться пропорционально количеству успешно пройденных тестов.
Sample Input: 10 AGTCCGTCAG
AGTGCCTCAG
Sample Output: 0.2

Ответы на вопрос

Ответил Аноним
0

PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018

Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadlnInteger;

 var s1 := ReadlnString;

 var s2 := ReadlnString;

 var k := s1.Zip(s2, (a, b)-> a <> b).Where(t -> t = True).Count;

 Writeln(Round(k / n, 7))

end.

Приложения:
Ответил Аноним
0
Я проверил, все работает. Отсюда скопировал текст и заново запустил.
Ответил Аноним
0
Видимо, у Вас неверно скопировалось. И еще, при ошибке четко показывается место... приведите контекст. И расскажите, как вводили исходные.
Ответил andrejskarin6825
0
на каком языке программирования написан код
Ответил Аноним
0
Да .... дожили.... прочитать две первых строки ЖИРНОГО ЗДОРОВЕННОГО ШРИФТА уже не в состоянии.
Ответил Аноним
0
В 14 лет... боже ты мой...
Новые вопросы