Информатика, вопрос задал AVLANIS , 7 лет назад

ДАЮ 30 БАЛЛОВ!
Программисту Владу очень грустно: на дворе Новый Год, но он не может принести домой ёлку, потому что у его кота Барсика аллергия. Помогите Владу написать программу, принимающую на вход целое положительное число N, и выводящую на экран последовательность от 1 до N "ёлочкой", чтобы у Влада хоть где-то она была.

Формат ввода
Строка, содержащая чило N.

Формат вывода
Ёлочка из нескольких строк.
НА PYTHON

Ответы на вопрос

Ответил protasovat757
0

n = int(input())

 

q = 1

s = 1

k = 0

while q <= n :

   print(q, end=' ')

   q = q + 1

   k = k + 1

   if k == s :

       print()

       s = s + 1

       k = 0

Новые вопросы