Информатика, вопрос задал Аноним , 2 года назад

даю 25 баллов написать программу на питоне!!!!!!!Ввести скобочное выражение со скобками двух видов. Определить, правильно ли расставлены скобки.
Пример: (([])) – правильно, ([)] – неправильно.

Ответы на вопрос

Ответил Аноним
0

Ответ:

def check(string):

   brackets_open = ('(', '[')

   brackets_closed = (')', ']')

   stack = []

   for i in string:

       if i in brackets_open:

           stack.append(i)

       if i in brackets_closed:    

           if len(stack) == 0:

               return False

           index = brackets_closed.index(i)

           open_bracket = brackets_open[index]

           if stack[-1] == open_bracket:

               stack = stack[:-1]  

           else: return False  

   return (not stack)

str=input()

print(check(str))

Объяснение:

Новые вопросы