Информатика, вопрос задал Milaaaaaaaaaa18 , 2 года назад

ДАЮ 23 БАЛЛОВ!♥️Напишите программу для нахождения добутку цыфр натурального числа N (ПАСКАЛЬ)
СРОЧНО, ПОЖАЛУЙСТА ♥️


LRSM: Какой класс, чтобы знать насколько коротко писать?

Ответы на вопрос

Ответил LRSM
0

Ответ:

  • var p, n: integer;
  • begin
  • readln(n);
  • p := 1;
  • while n <> 0 do
  • begin
  • if (n mod 10)<>0 then p := p * (n mod 10);
  • n := n div 10;
  • end;
  • writeln(p);
  • end.

Пример работоспособности:

Приложения:
Новые вопросы