ДАЮ 20 БАЛЛОВ ЗА РЕШЕНИЕ ЗАДАЧИ ПО С++!!!!!!!!!!!!
Дан массив a из n целых чисел. Требуется вывести только элементы, оканчивающиеся нулем.
Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.
Формат выходных данных
Требуется в одной строке через пробел вывести все числа, оканчивающиеся нулем, в том же порядке, в каком они расположены во входном файле.
входные данные
4
100 -20 4 318
10
-42 70 59 76 21 47 77 66 89 60
выходные данные
100 -20
70 60
Grey0808:
Снова не на Python'е
Ответы на вопрос
Ответил gbsnat
1
#include <iostream>
using namespace std;
signed main(){
int n, x;
cin >> n;
while(n--){
cin >> x;
if(x % 10 == 0)
cout << x << " ";
}
}
Новые вопросы