Информатика, вопрос задал nya7771 , 8 лет назад

ДАЮ 20 БАЛЛОВ!!!
Помогите написать программу в Паскале!!!
Даны 3 стороны треугольника.надо найти площадь(по формуле герона)

Ответы на вопрос

Ответил ForaN777
0
var a,b,c,p,S:real;
begin
writeln('Введите A: ');readln(a);
writeln('Введите B: ');readln(b);
writeln('Введите C: ');readln(c);
if (a+b>c) and (b+c>a) and (a+c>b) and (a>0) and (b>0) and (c>0) then
begin
p:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S = ',s)
end 
else
writeln('Стороны треугольникавведены неверно!');
end.
Новые вопросы