Информатика, вопрос задал sava19892006 , 2 года назад

Даю 15 балов Решите на Python Сумма квадратов По данному натуральному n вычислите сумму 12+22+32+...+n2. Входные данные Вводится натуральное число, не превосходящее 100. Выходные данные Выведите ответ на задачу. Примеры Ввод Вывод 3 14

Ответы на вопрос

Ответил DNHelper
5

Алгоритм: есть несколько способов решить эту задачу, смотря что от Вас требуется. Можно реализовать цикл, который каждый раз прибавляет к сумме квадрат следующего числа (сложность O(n)), а можно воспользоваться формулой 1^2+2^2+\ldots+n^2=\dfrac{n(n+1)(2n+1)}{6} и сразу выдать верный ответ (сложность O(1)).

Решение с помощью цикла:

s = 0

for i in range(1, int(input())+1):

   s += i*i

print(s)

Решение с помощью формулы:

n = int(input())

print(n*(n+1)*(2*n+1) // 6)

Новые вопросы