Информатика, вопрос задал mishakosmos1990 , 1 год назад

даю 100 баллов! Помогите составить программу в Паскаль
Задача "Часы информатики":
Количество классов в школе, изучающих информатику - 14.
У всех есть 1 урок в неделю. Но классы делятся на две
подгруппы, если в них 16 учащихся или больше. Во всех
классах случайное количество учащихся, но не менее 14 и не
более 35.
Сколько всего учащихся изучают информатику?
Сколько часов информатики в школе в неделю?

Ответы на вопрос

Ответил mirageKZ
0

var

 i, p, gr, uch: integer;

begin

 Randomize;

 gr:=0;

 uch:=0;

 for i:=1 to 14 do begin

   p:=random(14,35);

   writeln(p);

   uch:=uch+p;

   if p>=16 then gr:=gr+2

   else gr:=gr+1;

 end;

 writeln('Всего учащихся изучают информатику = ', uch);

 writeln('Часов информатики в школе в неделю = ', gr);

end.

Приложения:
Новые вопросы