Даны x,y,z. Напишите программу для вычисления значения арифметических выражений .
1.a=x+y-z/x2+2
2.a=5 2x-z/3+y2
(/ дробь)
Ответы на вопрос
Ответил ЯковПервый
0
Program Test,
Var x, y, z: integer; a1, a2: real;
Begin
Writeln('Введите значения х, y, z');
Readln(x, y, z);
a1 := (x + y - z) / (x * 2 + 2);
a2 := 5 * ((2 * x - z) / (3 + y * 2));
Writeln();
Writeln('a1 = ', a1);
Writeln('a2 = ', a2);
End.
-----------------------
P.S. Программа на паскале; На будующее - пиши условие задачи понятнее. Не х2, а х * 2 или 2х, а то это можно посчитать как х^2
Ответ к заданию 1 - это а1, а к заданию 2 - это а2
Var x, y, z: integer; a1, a2: real;
Begin
Writeln('Введите значения х, y, z');
Readln(x, y, z);
a1 := (x + y - z) / (x * 2 + 2);
a2 := 5 * ((2 * x - z) / (3 + y * 2));
Writeln();
Writeln('a1 = ', a1);
Writeln('a2 = ', a2);
End.
-----------------------
P.S. Программа на паскале; На будующее - пиши условие задачи понятнее. Не х2, а х * 2 или 2х, а то это можно посчитать как х^2
Ответ к заданию 1 - это а1, а к заданию 2 - это а2
Ответил Margino5555999926663
0
Спасибо тебе большое.Но 2 это степень.
Ответил ЯковПервый
0
Тогда напишиши не x * 2, а x * x
Ответил Margino5555999926663
0
Хорошо
Новые вопросы
Другие предметы,
2 года назад
История,
2 года назад
Алгебра,
8 лет назад
Обществознание,
9 лет назад