Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если такой треугольник существует, то определите его тип(равносторонний, равнобедренный, разносторонний).
Приложения:

Ответы на вопрос
Ответил sasasagagaga
0
var a, b, c: integer;begin
readln(a, b, c);
if (a + b <= c) or (b + c <= a) or (a + c <= b) then
writeln('Does not exist')
else if(a = b)and(b = c) then
writeln('Equilateral')
else if(a = b)or(b = c)or(a = c) then
writeln('Isosceles')
else
writeln('Versatile')
end.
readln(a, b, c);
if (a + b <= c) or (b + c <= a) or (a + c <= b) then
writeln('Does not exist')
else if(a = b)and(b = c) then
writeln('Equilateral')
else if(a = b)or(b = c)or(a = c) then
writeln('Isosceles')
else
writeln('Versatile')
end.
Новые вопросы
Окружающий мир,
2 года назад
Русский язык,
2 года назад
Математика,
10 лет назад
Алгебра,
10 лет назад
Математика,
10 лет назад