Даны три целых числа.Напишите программу ,подсчитывающую сумму тех чисел ,которые являются нечетными
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,c):=ReadInteger3('Введите три целых числа:');
var s:=0;
if a.IsOdd then s+=a;
if b.IsOdd then s+=b;
if c.IsOdd then s+=c;
Writeln('сумма нечетных равна ',s)
end.
Пример
Введите три целых числа: 345423 -324342 1231
сумма нечетных равна 346654
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,c):=ReadInteger3('Введите три целых числа:');
var s:=0;
if a.IsOdd then s+=a;
if b.IsOdd then s+=b;
if c.IsOdd then s+=c;
Writeln('сумма нечетных равна ',s)
end.
Пример
Введите три целых числа: 345423 -324342 1231
сумма нечетных равна 346654
Новые вопросы