Информатика, вопрос задал qosimbetovatt , 8 лет назад

Даны натуральное число N (<50) и числовой массив А[1..N]. Составить программу, которая определяет сумму минимального элемента множества {А1; А3;...} и максимального элемента множества {А2;А4;...}.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-99,99); a.Println;
  var minOdd:=Range(0,n-1,2).Select(i->a[i]).Min;
  var maxEven:=Range(1,n-1,2).Select(i->a[i]).Max;
  Writeln('Искомая сумма равна ',minOdd+maxEven)
end.

Пример
n= 15
-44 -48 -14 63 -34 27 -16 66 15 -17 -33 69 53 58 -31
Искомая сумма равна 25
Ответил qosimbetovatt
0
Спасибо. Пожалуйста составьте прог. на языке Турбо паскаль
Новые вопросы