Даны две точки: A(x1, y1) и B(x2, y2). Напишите программу, которая определяет, какая из точек находится дальше начала координат. Java
Ответы на вопрос
Відповідь:
Покрокове пояснення:
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner koordinats = new Scanner(System.in);
int x1 = koordinats.nextInt();
int y1 = koordinats.nextInt();
int x2 = koordinats.nextInt();
int y2 = koordinats.nextInt();
double Along = Math.sqrt(x1*x1+y1*y1);
double Blong = Math.sqrt(x2*x2+y2*y2);
if (Along > Blong) System.out.println("Точка А дальше от начала координат, нежели точа В");
else if (Along < Blong) System.out.println("Точка В дальше от начала координат, нежели точа А");
else System.out.println("Точки А и В находятся на одинаковом расстоянии от начала координат");
}
}