Даны две дроби a b и c d
Напишите программу, которая находит целую часть их суммы.
Входные данные В первой строке указаны через пробел целые числа a, b, c и d
(1 6 a, b, c, d 6 100).
Результат Выведите целую часть суммы a
b + c=d
выразить в программу паскаль
Ответы на вопрос
Ответил AnonimusPro
1
Для начала решим это математически:
Пусть и
- данные дроби.
Их сумма будет:
И нужно найти целую часть от деления (a*d+b*c) на (b*d).
Теперь составляем программу:
var a,b,c,d: integer;
begin
readln(a,b,c,d);
write(abs(a*d+b*c) div abs(b*d));
end.
Новые вопросы
География,
1 год назад
Геометрия,
1 год назад
Алгебра,
1 год назад
Русский язык,
1 год назад
Математика,
7 лет назад