Информатика, вопрос задал DoryDoll , 6 лет назад

Даны два вещественных числа. Составьте программу для нахождения коэффициентов приведённого квадратного уравнения, корнями которого являются эти числа.
8 Класс
даю 100 баллов ​


LuciFear45: какой язык
DoryDoll: это информатика 8 класс.Вводим всё на английском вроде как
LuciFear45: при чём тут это
LuciFear45: лол
LuciFear45: какой язык программирования?
LuciFear45: python? pascal? c++?
LuciFear45: на чём код писать то
DoryDoll: IDLE (Python)
LuciFear45: оки

Ответы на вопрос

Ответил stglupa
0

def findB(y1, y2):

   return -(y1 + y2)

def findC(y1, y2):

   return y1 * y2

def constructEquation(y1, y2):

   s = "x^2 "

   b, c = findB(y1, y2), findC(y1, y2)

   if b > 0:

       s += "+"

   s += str(b) + "x "

   if c > 0:

       s += "+"

   s += str(c) + " = 0"

   return s

def solve():

   x1, x2 = map(float, input().split())

   print(constructEquation(x1, x2))

solve()

Новые вопросы