Информатика, вопрос задал vlas39317 , 2 года назад

Даны два одномерных массива А и В состоящие из N целых
чисел каждый. Массив А заполнен числами в интервале от -43 до +47, а
массив В от -36 до +51. Написать программу, которая формирует новый
массив С, элементами которого является среднее арифметическое
Соответствующих элементов массива А и В.
Помогите пожалуйста!!!
Задача на Pascal​

Ответы на вопрос

Ответил nastikots
1

Ответ:

program z1;

var i,N:integer;

A:array [1..315] of integer;

B:array [1..315] of integer;

C:array [1..315] of real;

begin

randomize;

write('Введите количество элементов массивов (N <= 315) N = ');

readln(N);

write('Массив А: ');

for i:=1 to N do

begin

A[i]:=random(91)-43;

write(A[i]:7)

end;

writeln;

write('Массив В: ');

for i:=1 to N do

begin

B[i]:=random(88)-36;

write(B[i]:7)

end;

writeln;

write('Массив С: ');

for i:=1 to N do

begin

C[i]:=(A[i] + B[i]) / 2;

write(C[i]:7:1)

end

end.

Объяснение:

Вводим количество элементов в массивах (N <= 315)

Заполняем первый массив и выводим на экран

Заполняем второй массив и выводим на экран

Формируем третий массив и выводим на экран


vlas39317: спасибо
Новые вопросы