Информатика, вопрос задал ayana2501200730 , 2 года назад

Даны два натуральных числа. Напишите программу, которая определяет, в каком из них: а) больше цифр. б) сумма цифр больше.
ПОМОГИТЕ ПЛИЗ НАПИШИТЕ ЕЩЁ ПРОГРАММУ, через 40 мин папа придёт и мне тогда будет кирдик, если я не сделаю​

Ответы на вопрос

Ответил nikitakreml
15

Ответ:

Ниже

Объяснение:

def numberSum(n):

   d = 0

   k = 0

   while n:

     d = n% 10

     n/=10

     k = k + d

   return k

def charSum(n):

   counter = 0

   while n:

       n /= 10

       counter+=1

   return counter

a = int(input())

b = int(input())

if numberSum(a) > numberSum(b):

   print("Сумма чисел больше в a")

elif numberSum(a) == numberSum(b):

   print("Сума цифр равна")

else:

   print("Сумма чисел больше в b")

if charSum(a) > charSum(b):

   print("Символов больше в a")

elif charSum(a) == charSum(b):

   print("Количество символов равно")

else:

   print("Символов больше в b")


nikitakreml: Я еще не до конца проверил
nikitakreml: Но основу берет
nikitakreml: Если что найду, отредактирую
ayana2501200730: Хорошо, спасибо ❤️
Новые вопросы