Информатика, вопрос задал frol12112001 , 9 лет назад

Даны действительные числа A,B,C. Составьте программу для вычесления max (A+B,C)-min (A+C,B).


Ответы на вопрос

Ответил Аноним
0
// PascalABC.Net
function max(a,b:real):real;
begin
  if a>b then max:=a else max:=b
end;

function min(a,b:real):real;
begin
  if a<b then min:=a else min:=b
end;

var
  a,b,c:real;
begin
  Write('Введите три числа через пробел: '); Read(a,b,c);
  Writeln('Результат: ',max(a+b,c)-min(a+c,b))
end.

Тестовое решение:
Введите три числа через пробел: 5 -2 3.8
Результат: 5.8

Ответил Аноним
0
Вообще-то, в ПаскальАВС функции минимум и максимум уже определены, так что можно писать программу, начиная со строки var. Но в более ранних версиях Паскаля этих функций нет.
Ответил frol12112001
0
Спасибо за ответ
Ответил Аноним
0
Для "спасибо" тут есть кнопочка. Голубая.
Новые вопросы