Дано вещественное число R и массив размера N. Найти элемент массива который наиболее близок к данному числу. Написать программу в Paskal, Lazarus.
Ответы на вопрос
Ответил psehard
0
program nearone;
var R,i,x,N:integer; a:array[1..10] of integer;
begin
for i:=1 to 10 do
begin
a[i]:=random(50);
writeln(a[i]);
end;
write('Число R ->');
readln(R);
x:=abs(a[1]-R);
N:=1;
for i:=2 to 10 do
if x > abs(a[i]-R) then
begin
x:=abs(a[i]-R);
N:=i;
end;
writeln('Ближайшее число - ',a[N]);
end.
var R,i,x,N:integer; a:array[1..10] of integer;
begin
for i:=1 to 10 do
begin
a[i]:=random(50);
writeln(a[i]);
end;
write('Число R ->');
readln(R);
x:=abs(a[1]-R);
N:=1;
for i:=2 to 10 do
if x > abs(a[i]-R) then
begin
x:=abs(a[i]-R);
N:=i;
end;
writeln('Ближайшее число - ',a[N]);
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Математика,
7 лет назад
Математика,
7 лет назад
Алгебра,
9 лет назад
Алгебра,
9 лет назад