Дано условие задачи и программа, ее решающая. Предложить набор тестов для проверки работоспособности программы.
Составить программу, печатающую значение TRUE, если указанное высказывание является истинным, и FALSE в противном случае:
1. Треугольник со сторонами a, b, c является равносторонним.
Var a, b, c : integer;
Begin
Writeln(' a, b, c? '); Readln(a, b, c);
Writeln( (a=b) and (b=c) and (a=c) )
End.
Ответы на вопрос
Ответил rklug
0
1) вводить три равных натуральных числа - треугольник равносторонний. Результат программы TRUE ⇒ программа работает корректно
2) вводить три неравных натуральных числа - треугольник не равносторонний. Результат программы FALSE ⇒ программа работает корректно
3) ввести три нуля - треугольник не существует. Результат программы TRUE ⇒ программа работает некорректно
4) вводить три равных отрицательных числа - треугольник не существует. Результат программы TRUE ⇒ программа работает некорректно
5) ввести три равных или неравных вещественных числа - треугольник существует. Результата программы нет (ошибка типов) ⇒ программа работает некорректно
2) вводить три неравных натуральных числа - треугольник не равносторонний. Результат программы FALSE ⇒ программа работает корректно
3) ввести три нуля - треугольник не существует. Результат программы TRUE ⇒ программа работает некорректно
4) вводить три равных отрицательных числа - треугольник не существует. Результат программы TRUE ⇒ программа работает некорректно
5) ввести три равных или неравных вещественных числа - треугольник существует. Результата программы нет (ошибка типов) ⇒ программа работает некорректно
Новые вопросы