Информатика, вопрос задал gajod26435 , 7 лет назад

Дано трехзначное случайное число. Написать программу, определяющую, является ли сумма десятков и единиц в нем однозначным числом. C#

Ответы на вопрос

Ответил restIess
1

using System;

namespace restless

{

   class Program

   {

       static void Main(string[] args)

       {

           Random rnd = new Random();

           int num = rnd.Next(100, 999);

           Console.WriteLine($"Наше сгенерированное число: {num}");

           num = Math.Abs(num);

           if (num % 10 + (num / 10) % 10 < 10)

               Console.WriteLine("Сумма десятков и единиц является однозначным числом");

           else

               Console.WriteLine("Сумма десятков и единиц не является однозначным числом");

           Console.ReadKey();

       }

   }

}


gajod26435: Console.WriteLine($"Наше сгенерированное число: {num}"); Что обозначает $?
restIess: Если простым языком, то этот знак означает нам, что мы можем в "{}" заключать имена переменных, которые будут выводится в строке
restIess: Интерполяция называется
Новые вопросы