Дано трехзначное натуральное число. Написать программу, которая определяет верно ли, что сумма цифр этого числа является нечетной ( число вводится с клавиатуры).
Ответы на вопрос
Ответил vladislavBaulin
0
var a,s:integer;begin readln(a); s:=a div 100+a div 10 mod 10+a mod 10; if s mod 2=1 then writeln('Верно. s = ',s,' - нечётна') else writeln('Нет. s = ',s,' - чётна')end.
Пример:251Нет. s = 8 - чётна
Пример:251Нет. s = 8 - чётна
Новые вопросы