Информатика, вопрос задал lavrysha16 , 10 лет назад

Дано трехзначное число abc. Напишите программу, позволяющую вывести на экран следующее двузначное число: a(b+c).

Ответы на вопрос

Ответил rustikpro
0
Программа в картинке.
Приложения:
Ответил lavrysha16
0
спасибо!!!
Ответил JustPeople
0
VAR
   s: String;
BEGIN
   Read(s);
   Write((Ord(s[1])-48)*(Ord(s[2]) + Ord(s[3]) - 96));
END.
Приложения:
Ответил Аноним
0
А чем плох StrToInt? По крайней мере, он откажется считать, если программе на вход подсунуть выражение типа "а12", выдаст ошибку, а с Ord она выдаст численный ответ, как будто все нормально. Не вижу причин для его использования.
Новые вопросы