Дано шестизначное число. Написать программу, которая определяетявляется ли оно счастливым (сумма первых трех цифр равна сумме последних трех). Если число счастливое вывести на экран слово HAPPY, в противном случае вывести на экран слово NO
(никакие поясняющие записи в программе делать не нужно! библиотеку conio.h и команду getch() перед отправкой файла необходимо удалить!)
в c++
Ответы на вопрос
Ответил Аноним
0
#include <iostream>
using namespace std;
int main()
{
int A;
int B,C;
cin >> A;
B=0;
for (int i = 1; i<=3; i++)
{
B+=A%10;
A = A / 10;
}
C=0;
for (int i = 1; i<=3; i++)
{
C+=A%10;
A = A / 10;
}
if (B==C) cout << "HAPPY" << endl;
else cout << "NO" << endl;
return 0;
}
using namespace std;
int main()
{
int A;
int B,C;
cin >> A;
B=0;
for (int i = 1; i<=3; i++)
{
B+=A%10;
A = A / 10;
}
C=0;
for (int i = 1; i<=3; i++)
{
C+=A%10;
A = A / 10;
}
if (B==C) cout << "HAPPY" << endl;
else cout << "NO" << endl;
return 0;
}
Новые вопросы