Информатика, вопрос задал Zpok , 8 лет назад

Дано неотрицательное число N- количество элементов массива (N<=100)

Заполнить массив первыми натуральными четырехзначными числами, у которых сумма четных цифр больше суммы нечетных

Пример входных и выходных данных
№ теста Входные данные Выходные данные
1 5 1002 1004 1006 1008 1014
НА С++

Ответы на вопрос

Ответил clinteastwood2
0
#include <iostream>
using namespace std;

int main()
{
unsigned l;
cout << "Enter size: ";
cin >> l;
int *a = new int[l];
for(int i = 1000, k=0; k < l && i < 10000; ++i) {
        int sum[2] = {0};
        for(int j = 1, n = i; j <= 4; ++j) {
            sum[(n % 10) % 2] += n % 10;
            n /= 10;
        }
        if(sum[0]>sum[1]) {
            a[k++] = i; 
        }
    }

    for(int i = 0; i < l; ++i){
        cout << a[i] << endl; 
}
delete[] a;
return 0;
}
Ответил Zpok
0
если бы я умел писать я бы не просил
Ответил Zpok
0
а мне надо с и без sum[(n % 10) % 2]+= n % 10;delete[] a; int sum[2] = {0};delete[] a;cout << "Enter size: "; а в for писать что то вродеi =0;i<N;i++
Ответил clinteastwood2
0
я вас не понимаю, сделал что вы просили, программа работает, и выдает нужный результат
Ответил Zpok
0
но мы то в школе походим с++ другого типа безum[(n % 10) % 2]+= n % 10;delete[] a; int sum[2] = {0};delete[] a;cout << "Enter size: "; а в for писать что то вродеi =0;i<N;i++
Ответил clinteastwood2
0
тогда блесните умом и подтяните свои знания по С++, здесь все очень понятно, я не использовал ничего нового, обычная математика, как вы просите сделать не получится
Новые вопросы