Информатика, вопрос задал flowergirl01 , 9 лет назад

Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч).

Ответы на вопрос

Ответил LikeFist
0
Program Pr1;
uses crt;
var fl1,fl2:text;
n,tmp:string;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
close(fl1);
tmp:=copy(n,length(n),1);
n:=tmp+n;
rewrite(fl2);
writeln(fl2,n);
close(fl2);
end.
Новые вопросы