Дано натуральное n, вычислить n! (0!=1, n! = n * (n-1)!). Написать программу на C#.
Ответы на вопрос
Ответил HomoNovus
0
class Program
{
static void Main(string[] args)
{
int res = 1;
Console.Write("Введите n: ");
int n = Convert.ToInt32(Console.ReadLine());
for(;n > 0; n--)
res *= n;
Console.Write("Результат: {0}",res);
Console.ReadLine();
}
}
{
static void Main(string[] args)
{
int res = 1;
Console.Write("Введите n: ");
int n = Convert.ToInt32(Console.ReadLine());
for(;n > 0; n--)
res *= n;
Console.Write("Результат: {0}",res);
Console.ReadLine();
}
}
Новые вопросы