Информатика, вопрос задал SashaKravche , 7 лет назад

Дано натуральное число. Написать программу, которая определит является ли число двузначным. Ответ: True или False и является ли четной сумма его цифр.
ПОЖАЛУЙСТА СРОЧНО Даю 50 баллов.​

Ответы на вопрос

Ответил lumos268
0

Python:

a = int(input())

s = 0

print("True") if len(str(a)) == 2 else print("False")

for i in str(a):

  s+=int(i)

print("сумма цифр чётная") if s % 2 == 0 else print("сумма цифр не чётная")

Ответил csharp
0
Изначально это целочисленное значение:
a = int(input())
То, что Вы в условии использовали функцию str(a) - ещё не делает эту переменную строкой, поскольку в функцию str() передаётся не ссылка на переменную a, а копия.
Ответил lumos268
0
дак речи и не шло, о том что переменная a делается строкой
Ответил csharp
0
Тогда каким образом переменная 'a' вначале становится символом?
Ответил lumos268
0
вы спросили про переменную i )
Ответил csharp
0
Слепой я)
Ответил csharp
0
  1. var
  2.  number: integer;
  3. begin
  4.  Readln(number);
  5.  if (number >= 10) and (number <= 99) then
  6.    begin
  7.      Writeln('True');
  8.      if (number div 10 + number mod 10) mod 2 = 0 then
  9.        Writeln('Сумма цифр чётна.')
  10.      else
  11.        Writeln('Сумма цифр нечётна.');
  12.    end
  13.  else
  14.    Writeln('False');
  15. end.
Новые вопросы