Информатика, вопрос задал Shakenaruna008 , 6 лет назад

Дано натуральное число N. Составьте программу, которая находит произведение цифр этого числа. ПОМОГИТЕ ПОЖАЛУЙСТА


fovfabomi: какой язык программирования?
Shakenaruna008: Я не очень понимаю информатику
Shakenaruna008: Но если не ошибаюсь Python
Shakenaruna008: Или ты спрашиваешь про другое?
fovfabomi: если python, то к сожалению я его не знаю.

Ответы на вопрос

Ответил fiveweek234
2

Ответ:from functools import reduce

number = input()

mp = lambda x,y: x*y

print(reduce(mp, [int(i) for i in number]))

Объяснение:

запрашиваем у пользователя число, создаем функцию, умнажающую одно число на другое и с помощью функции reduce и mp находим произведение цифр

Ответил restIess
1

N = int(input("Введите натуральное число: "))

prod = 1

while N > 0:

   prod *= N % 10

   N //= 10

print(prod)

Новые вопросы