Дано натуральное число N. Напишите функцию (Pascal), определяющую количество нулей среди всех цифр числа N.
Входные данные
Задано единственное число N
Выходные данные
Необходимо вывести количество нулей среди всех цифр числа N.
Примеры
входные данные
100
выходные данные
2
Ответы на вопрос
Ответил Аноним
0
function ABC(A:integer):integer;
Begin
result:=0;
While A>0 do
Begin
if A mod 10 = 0 then result:=result+1;
A:=A div 10;
End;
End;
Var A:integer;
Begin
Read(A);
WriteLn(ABC(A));
End.
Begin
result:=0;
While A>0 do
Begin
if A mod 10 = 0 then result:=result+1;
A:=A div 10;
End;
End;
Var A:integer;
Begin
Read(A);
WriteLn(ABC(A));
End.
Ответил Аноним
0
Ни малейшего понятия не имею о том, что именно Вы проходили
Новые вопросы