Информатика, вопрос задал Misha090695 , 10 лет назад

Дано: массив целых чисел A[N].Проверьте, есть ли в нем отрицательные элементы.Если есть, найдите наибольшее i, при котором A[i]<0, иначе выведите сообщение. Напишите программу для Паскаль или лазарус

Ответы на вопрос

Ответил kage1998
0
program gt;
var a:array[1..1000]of integer;
i,n,l:integer;
begin
read(n);
l:=0;
for i:=1 to n do
begin
read(a[i]);
if(a[i]<0)then l:=i;
end;
if(l=0)then writeln('НЕТ ОТРИЦА... В массиве')else writeln(l);
end.
Ответил buster515
0
у меня в любом случае пишет "нет отрицательных"
Ответил Adequate
0
Программа не правильная
Новые вопросы