Дано четырёхзначное число, составьте программу с которой определите, равняются ли в нем произведение средних цифр и сумма крайних цифр.
!СРОЧНО!
megaamir555:
какой ЯП?
Ответы на вопрос
Ответил jenea9833
0
Ответ:
program ravn_kvsred_pr_krai;
var
x:integer;
begin
read(x);
if((x div 1000)*(x mod 10))=((x div 10 mod 10)*(x div 10 mod 10)+(x mod 100 div 10)*(x mod 100 div 10))
then
write('да')
else
write('нет')
end.
Объяснение:
Погонял программу, работает, надеюсь помог
Новые вопросы
Английский язык,
2 года назад
Українська література,
2 года назад
Математика,
2 года назад
Алгебра,
8 лет назад